Development Tools and Code

This describes the recommended toolset for development. Other editors and IDEs may work as well, but this is probably the easiest way to get up and running.

  • Install the Atom editor.
  • Install the atom-ide-ui package. To install a package from within the Atom editor, select Preferences then Install then search for the package.
  • Install the atom-typescript package from within the Atom editor.
  • Download the Blocks scripting github repo as a ZIP file and unpack it into the script directory. This is located inside PIXILAB-Blocks-root in your home directory (assuming the Blocks server program has been used on this computer, thus creating the script folder).

:!: If you already have some of the files or directories matching those obtained from github on your computer, you need to merge the files with the existing ones, replacing any conflicting files as appropriate.

Once this is done, your PIXILAB-Blocks-root/script directory should contain at least the following items

driver
system
system_lib
LICENSE
README.md
tsconfig.json

The first three items shown above are directories, containing the files obtained from github. They may contain additional files, if you had driver or other scripts installed before.

Once you have those pieces in place, restart your local Blocks server and open the Blocks Editor using your web browser. You should now find the drivers on the Driver menu of a TCP Device added on the Manage page. If you don't see the drivers listed there, they're not installed in the proper location (see above).

Proceed with learning about basic concepts.